networking_wiki:port_channels

This is an old revision of the document!


Port Channels (Ether Channels)

This is to configure port channels (link aggregation) on Cisco switches.

1) Create the virtual port channel:

interface Port-channel2
 description Server1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk

2) On each physical switch interface, include it as part of the group.

interface GigabitEthernet2/0/1
 description Server1 port 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 2 mode active

interface GigabitEthernet2/0/2
 description Server1 port 2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 2 mode active

interface GigabitEthernet2/0/3
 description Server1 port 3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 2 mode active
  • networking_wiki/port_channels.1416530011.txt.gz
  • Last modified: 2019/05/25 23:50
  • (external edit)